import re
regex = re.compile(r".*;(.*);.*$", flags=re.MULTILINE)
test_str = ("220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad\n"
"220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad\n"
"221;Paul;30;23/11/2008;22/12/2008;He is a Software engineer at MNC;Bangalore\n"
"222;Emma;23/11/2008;22/12/200825;Working as a mechanical enginner;Chennai\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")