re = /.*;(.*);.*$/m
str = '220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad
220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad
221;Paul;30;23/11/2008;22/12/2008;He is a Software engineer at MNC;Bangalore
222;Emma;23/11/2008;22/12/200825;Working as a mechanical enginner;Chennai
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end