import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*;(.*);.*$";
final String string = "220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad\n"
+ "220;John;23/11/2008;22/12/2008;28;Working as a Professor in University;Hyderabad\n"
+ "221;Paul;30;23/11/2008;22/12/2008;He is a Software engineer at MNC;Bangalore\n"
+ "222;Emma;23/11/2008;22/12/200825;Working as a mechanical enginner;Chennai\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}