#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!\d+,\d+\.\d+,|\d+\.\d+,\d+.)^([+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*)(?:[.,]\d+|[eE][+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*))?)$"
Local $sString = "1" & @CRLF & _
"1.1" & @CRLF & _
"1,1" & @CRLF & _
"1,000,000.20" & @CRLF & _
"1.00000020" & @CRLF & _
"1.000.000,20" & @CRLF & _
"10.20001" & @CRLF & _
"24568221.94827" & @CRLF & _
"347,543,291.01" & @CRLF & _
"12e20" & @CRLF & _
"1e9" & @CRLF & _
"1e-9" & @CRLF & _
"1,009e10" & @CRLF & _
"10009e10" & @CRLF & _
"123,456.543" & @CRLF & _
"+123,456,789" & @CRLF & _
"-123,456,789" & @CRLF & _
"" & @CRLF & _
"1,234583,213" & @CRLF & _
"1.234,568.78" & @CRLF & _
"123,456.543,456"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")