use strict;
my $str = '1
1.1
1,1
1,000,000.20
1.00000020
1.000.000,20
10.20001
24568221.94827
347,543,291.01
12e20
1e9
1e-9
1,009e10
10009e10
123,456.543
+123,456,789
-123,456,789
1,234583,213
1.234,568.78
123,456.543,456';
my $regex = qr/(?!\d+,\d+\.\d+,|\d+\.\d+,\d+.)^([+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*)(?:[.,]\d+|[eE][+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*))?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}