re = /(?!\d+,\d+\.\d+,|\d+\.\d+,\d+.)^([+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*)(?:[.,]\d+|[eE][+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*))?)$/m
str = '1
1.1
1,1
1,000,000.20
1.00000020
1.000.000,20
10.20001
24568221.94827
347,543,291.01
12e20
1e9
1e-9
1,009e10
10009e10
123,456.543
+123,456,789
-123,456,789
1,234583,213
1.234,568.78
123,456.543,456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end