# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?!\d+,\d+\.\d+,|\d+\.\d+,\d+.)^([+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*)(?:[.,]\d+|[eE][+-]?(?:\d+|\d{1,3}(?:[.,]\d{3})*))?)$"
test_str = ("1\n"
"1.1\n"
"1,1\n"
"1,000,000.20\n"
"1.00000020\n"
"1.000.000,20\n"
"10.20001\n"
"24568221.94827\n"
"347,543,291.01\n"
"12e20\n"
"1e9\n"
"1e-9\n"
"1,009e10\n"
"10009e10\n"
"123,456.543\n"
"+123,456,789\n"
"-123,456,789\n\n"
"1,234583,213\n"
"1.234,568.78\n"
"123,456.543,456")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.