import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!\\d+,\\d+\\.\\d+,|\\d+\\.\\d+,\\d+.)^([+-]?(?:\\d+|\\d{1,3}(?:[.,]\\d{3})*)(?:[.,]\\d+|[eE][+-]?(?:\\d+|\\d{1,3}(?:[.,]\\d{3})*))?)$";
final String string = "1\n"
+ "1.1\n"
+ "1,1\n"
+ "1,000,000.20\n"
+ "1.00000020\n"
+ "1.000.000,20\n"
+ "10.20001\n"
+ "24568221.94827\n"
+ "347,543,291.01\n"
+ "12e20\n"
+ "1e9\n"
+ "1e-9\n"
+ "1,009e10\n"
+ "10009e10\n"
+ "123,456.543\n"
+ "+123,456,789\n"
+ "-123,456,789\n\n"
+ "1,234583,213\n"
+ "1.234,568.78\n"
+ "123,456.543,456";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}