#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<variable>\w+)(?:\.(?<subvariable>\w+(?:\.\w+)*))??(?:\.(?<method>\w+)\((?<parameter>[^{}%\n]*)\))?$"
Local $sString = "core.settings" & @CRLF & _
" => $core['settings'] " & @CRLF & _
"core.set(param1, param2)" & @CRLF & _
" => $core->set('param1', 'param2')" & @CRLF & _
"core.settings" & @CRLF & _
"core.get(param)" & @CRLF & _
"core.settings.time" & @CRLF & _
"core.settings.time.set(param)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")