import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<variable>\\w+)(?:\\.(?<subvariable>\\w+(?:\\.\\w+)*))??(?:\\.(?<method>\\w+)\\((?<parameter>[^\\{\\}%\\n]*)\\))?$";
final String string = "core.settings\n"
+ " => $core['settings'] \n"
+ "core.set(param1, param2)\n"
+ " => $core->set('param1', 'param2')\n"
+ "core.settings\n"
+ "core.get(param)\n"
+ "core.settings.time\n"
+ "core.settings.time.set(param)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}