const regex = /^(?<variable>\w+)(?:\.(?<subvariable>\w+(?:\.\w+)*))??(?:\.(?<method>\w+)\((?<parameter>[^{}%\n]*)\))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<variable>\\w+)(?:\\.(?<subvariable>\\w+(?:\\.\\w+)*))??(?:\\.(?<method>\\w+)\\((?<parameter>[^{}%\\n]*)\\))?$', 'gm')
const str = `core.settings
=> \$core['settings']
core.set(param1, param2)
=> \$core->set('param1', 'param2')
core.settings
core.get(param)
core.settings.time
core.settings.time.set(param)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}