$re = '/^(?<variable>\w+)(?:\.(?<subvariable>\w+(?:\.\w+)*))??(?:\.(?<method>\w+)\((?<parameter>[^{}%\n]*)\))?$/m';
$str = 'core.settings
=> $core[\'settings\']
core.set(param1, param2)
=> $core->set(\'param1\', \'param2\')
core.settings
core.get(param)
core.settings.time
core.settings.time.set(param)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);