re = /^(?<variable>\w+)(?:\.(?<subvariable>\w+(?:\.\w+)*))??(?:\.(?<method>\w+)\((?<parameter>[^{}%\n]*)\))?$/m
str = 'core.settings
=> $core[\'settings\']
core.set(param1, param2)
=> $core->set(\'param1\', \'param2\')
core.settings
core.get(param)
core.settings.time
core.settings.time.set(param)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end