using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?):\/\/(grabify|truelove|lovebird|dateing|shrekis|headshot|gaming-at-my|progaming|yourmy|imageshare|screenshot|gamingfun|catsnthings?|curiouscat|joinmy|fortnitechat|fortnight|freegiftcards|stopify|leancoding)\.(guru|club|life|monster|best|me|com|fun|site|space|co|link)\/([a-z 0-9]{6})";
string input = @"https://grabify.co/EEAR83";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}