package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(https?):\/\/(grabify|truelove|lovebird|dateing|shrekis|headshot|gaming-at-my|progaming|yourmy|imageshare|screenshot|gamingfun|catsnthings?|curiouscat|joinmy|fortnitechat|fortnight|freegiftcards|stopify|leancoding)\.(guru|club|life|monster|best|me|com|fun|site|space|co|link)\/([a-z 0-9]{6})`)
var str = `https://grabify.co/EEAR83`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}