// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(https?):\/\/(grabify|truelove|lovebird|dateing|shrekis|headshot|gaming-at-my|progaming|yourmy|imageshare|screenshot|gamingfun|catsnthings?|curiouscat|joinmy|fortnitechat|fortnight|freegiftcards|stopify|leancoding)\.(guru|club|life|monster|best|me|com|fun|site|space|co|link)\/([a-z 0-9]{6})").unwrap();
let string = "https://grabify.co/EEAR83";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}