import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?):\\/\\/(grabify|truelove|lovebird|dateing|shrekis|headshot|gaming-at-my|progaming|yourmy|imageshare|screenshot|gamingfun|catsnthings?|curiouscat|joinmy|fortnitechat|fortnight|freegiftcards|stopify|leancoding)\\.(guru|club|life|monster|best|me|com|fun|site|space|co|link)\\/([a-z 0-9]{6})";
final String string = "https://grabify.co/EEAR83";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}