re = /(https?):\/\/(grabify|truelove|lovebird|dateing|shrekis|headshot|gaming-at-my|progaming|yourmy|imageshare|screenshot|gamingfun|catsnthings?|curiouscat|joinmy|fortnitechat|fortnight|freegiftcards|stopify|leancoding)\.(guru|club|life|monster|best|me|com|fun|site|space|co|link)\/([a-z 0-9]{6})/i
str = 'https://grabify.co/EEAR83'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end