using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+(?=\s+file1\b)";
string input = @"123123abc file2
274efcc4d8a0e8f61397be46bd4bfa37 file1
321 file1";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}