import Foundation
let pattern = #"\w+(?=\s+file1\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
123123abc file2
274efcc4d8a0e8f61397be46bd4bfa37 file1
321 file1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}