$re = '/\w+(?=\s+file1\b)/';
$str = '123123abc file2
274efcc4d8a0e8f61397be46bd4bfa37 file1
321 file1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);