#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)(href="[a-zA-Z\/-]+\.x?html#)(?-i)([a-z]+?_[-a-z]*)([A-Z])"
Local $sString = "<a href="/premium-classic/before-you-start.xhtml#sub_InstallingLightroom">Installing Lightroom</a>" & @CRLF & _
"<a href="/premium-classic/before-you-start.xhtml#box_MultipleComputers">Multiple Computers</a>" & @CRLF & _
" <a href="/premium-classic/before-you-start.xhtml#sub_KeepingLightroomUpdated">Keeping Lightroom Updated</a>" & @CRLF & _
"<a href="/premium-classic/managing-your-photos.xhtml#sub_ManagingFoldersInLightroomAndOnTheHardDrive">Managing Folders in Lightroom and on the Hard Drive</a>" & @CRLF & _
"<a href="/premium-classic/managing-your-photos.xhtml#sub_ChangingTheFolderStructure">Changing the Folder Structure</a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")