const regex = /(?i)(href="[a-zA-Z\/-]+\.x?html#)(?-i)([a-z]+?_[-a-z]*)([A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)(href="[a-zA-Z\\\/-]+\\.x?html#)(?-i)([a-z]+?_[-a-z]*)([A-Z])', 'gm')
const str = `<a href="/premium-classic/before-you-start.xhtml#sub_InstallingLightroom">Installing Lightroom</a>
<a href="/premium-classic/before-you-start.xhtml#box_MultipleComputers">Multiple Computers</a>
<a href="/premium-classic/before-you-start.xhtml#sub_KeepingLightroomUpdated">Keeping Lightroom Updated</a>
<a href="/premium-classic/managing-your-photos.xhtml#sub_ManagingFoldersInLightroomAndOnTheHardDrive">Managing Folders in Lightroom and on the Hard Drive</a>
<a href="/premium-classic/managing-your-photos.xhtml#sub_ChangingTheFolderStructure">Changing the Folder Structure</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}