$re = '/(?i)(href="[a-zA-Z\/-]+\.x?html#)(?-i)([a-z]+?_[-a-z]*)([A-Z])/m';
$str = '<a href="/premium-classic/before-you-start.xhtml#sub_InstallingLightroom">Installing Lightroom</a>
<a href="/premium-classic/before-you-start.xhtml#box_MultipleComputers">Multiple Computers</a>
<a href="/premium-classic/before-you-start.xhtml#sub_KeepingLightroomUpdated">Keeping Lightroom Updated</a>
<a href="/premium-classic/managing-your-photos.xhtml#sub_ManagingFoldersInLightroomAndOnTheHardDrive">Managing Folders in Lightroom and on the Hard Drive</a>
<a href="/premium-classic/managing-your-photos.xhtml#sub_ChangingTheFolderStructure">Changing the Folder Structure</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);