using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(href=""[a-zA-Z\/-]+\.x?html#)(?-i)([a-z]+?_[-a-z]*)([A-Z])";
string input = @"<a href=""/premium-classic/before-you-start.xhtml#sub_InstallingLightroom"">Installing Lightroom</a>
<a href=""/premium-classic/before-you-start.xhtml#box_MultipleComputers"">Multiple Computers</a>
<a href=""/premium-classic/before-you-start.xhtml#sub_KeepingLightroomUpdated"">Keeping Lightroom Updated</a>
<a href=""/premium-classic/managing-your-photos.xhtml#sub_ManagingFoldersInLightroomAndOnTheHardDrive"">Managing Folders in Lightroom and on the Hard Drive</a>
<a href=""/premium-classic/managing-your-photos.xhtml#sub_ChangingTheFolderStructure"">Changing the Folder Structure</a>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}