package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(href="[a-zA-Z\/-]+\.x?html#)(?-i)([a-z]+?_[-a-z]*)([A-Z])`)
var str = `<a href="/premium-classic/before-you-start.xhtml#sub_InstallingLightroom">Installing Lightroom</a>
<a href="/premium-classic/before-you-start.xhtml#box_MultipleComputers">Multiple Computers</a>
<a href="/premium-classic/before-you-start.xhtml#sub_KeepingLightroomUpdated">Keeping Lightroom Updated</a>
<a href="/premium-classic/managing-your-photos.xhtml#sub_ManagingFoldersInLightroomAndOnTheHardDrive">Managing Folders in Lightroom and on the Hard Drive</a>
<a href="/premium-classic/managing-your-photos.xhtml#sub_ChangingTheFolderStructure">Changing the Folder Structure</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}