# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\w+)(?<=in)/$1-/gm;t' <<< "in (one, two, three)
in (one, two, three, four)
sdsdggd, asfafs
allalalalal
// asfasf fas"