re = /(\w+)(?<=in)/m
str = 'in (one, two, three)
in (one, two, three, four)
sdsdggd, asfafs
allalalalal
// asfasf fas'
subst = '$1-'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result