$re = '/(\w+)(?<=in)/m';
$str = 'in (one, two, three)
in (one, two, three, four)
sdsdggd, asfafs
allalalalal
// asfasf fas';
$subst = "$1-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;