use strict;
my $str = 'in (one, two, three)
in (one, two, three, four)
sdsdggd, asfafs
allalalalal
// asfasf fas';
my $regex = qr/(\w+)(?<=in)/mp;
my $subst = '$1-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";