#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w+)(?<=in)"
Local $sString = "in (one, two, three)" & @CRLF & _
" in (one, two, three, four)" & @CRLF & _
"" & @CRLF & _
"sdsdggd, asfafs" & @CRLF & _
"allalalalal" & @CRLF & _
"" & @CRLF & _
"// asfasf fas"
Local $sSubst = "$1-"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)