#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+(?=_\d{14})"
Local $sString = "History Performance_GSM_CSPS Traffic_CA_Dashboard KPI_20200817205834_3" & @CRLF & _
"History Performance_LTE_PS Traffic_CA_Dashboard KPI_20200817205834_3" & @CRLF & _
"History Performance_UMTS_CSPS Traffic_CA_Dashboard KPI_20200817205834_3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")