const regex = /.+(?=_\d{14})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+(?=_\\d{14})', 'gm')
const str = `History Performance_GSM_CSPS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_LTE_PS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_UMTS_CSPS Traffic_CA_Dashboard KPI_20200817205834_3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}