import Foundation
let pattern = #".+(?=_\d{14})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
History Performance_GSM_CSPS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_LTE_PS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_UMTS_CSPS Traffic_CA_Dashboard KPI_20200817205834_3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)