$re = '/.+(?=_\d{14})/m';
$str = 'History Performance_GSM_CSPS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_LTE_PS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_UMTS_CSPS Traffic_CA_Dashboard KPI_20200817205834_3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);