using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(?=_\d{14})";
string input = @"History Performance_GSM_CSPS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_LTE_PS Traffic_CA_Dashboard KPI_20200817205834_3
History Performance_UMTS_CSPS Traffic_CA_Dashboard KPI_20200817205834_3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}