#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:Name|Age):\h*((?:.(?!(?:Name|Age):))+)"
Local $sString = "fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk " & @CRLF & _
"Name: Max Pain" & @CRLF & _
"Age: 99 Years" & @CRLF & _
"and they df;ml dk fdj,nbfdlkn ......" & @CRLF & _
"" & @CRLF & _
"fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk " & @CRLF & _
"Name: Max Pain Age: 99 Years" & @CRLF & _
"and they df;ml dk fdj,nbfdlkn ......"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")