const regex = /\b(?:Name|Age):\h*((?:.(?!(?:Name|Age):))+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?:Name|Age):\\h*((?:.(?!(?:Name|Age):))+)', 'gm')
const str = `fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain
Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......
fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}