re = /\b(?:Name|Age):\h*((?:.(?!(?:Name|Age):))+)/m
str = 'fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain
Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......
fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end