$re = '/\b(?:Name|Age):\h*((?:.(?!(?:Name|Age):))+)/m';
$str = 'fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain
Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......
fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);