using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:Name|Age):\h*((?:.(?!(?:Name|Age):))+)";
string input = @"fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain
Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......
fhsdgjfsdk;snfd fsd ;lknf;ksld sldkfj lk
Name: Max Pain Age: 99 Years
and they df;ml dk fdj,nbfdlkn ......";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}