package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\(?\s?\d{2,3}\s?\)?)?\s?([789]\d{3})\s?-?(\d{4})$`)
var str = `(51) 9989-1245
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}