re = /^(\(?\s?\d{2,3}\s?\)?)?\s?([789]\d{3})\s?-?(\d{4})$/
str = '(51) 9989-1245
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end