const regex = /^(\(?\s?\d{2,3}\s?\)?)?\s?([789]\d{3})\s?-?(\d{4})$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\(?\\s?\\d{2,3}\\s?\\)?)?\\s?([789]\\d{3})\\s?-?(\\d{4})$', 'g')
const str = `(51) 9989-1245
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}