// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(\(?\s?\d{2,3}\s?\)?)?\s?([789]\d{3})\s?-?(\d{4})$").unwrap();
let string = "(51) 9989-1245
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}