using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(creatinine).*?(\d+)\D*(\d+\s*-\s*\d+)?";
string input = @"TEST RESULT\.br\COLLECTION DATE 6-FEB-2014\.br\24 HOUR URINE VOLUME 0.100\.br\\.br\SERUM CREATININE LEVEL 511 HI 64 - 110";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}