// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(creatinine).*?(\d+)\D*(\d+\s*-\s*\d+)?").unwrap();
let string = "TEST RESULT\\.br\\COLLECTION DATE 6-FEB-2014\\.br\\24 HOUR URINE VOLUME 0.100\\.br\\\\.br\\SERUM CREATININE LEVEL 511 HI 64 - 110";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}