# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(creatinine).*?(\d+)\D*(\d+\s*-\s*\d+)?"
test_str = "TEST RESULT\\.br\\COLLECTION DATE 6-FEB-2014\\.br\\24 HOUR URINE VOLUME 0.100\\.br\\\\.br\\SERUM CREATININE LEVEL 511 HI 64 - 110"
matches = re.search(regex, test_str, re.IGNORECASE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.