use strict;
my $str = 'TEST RESULT\\.br\\COLLECTION DATE 6-FEB-2014\\.br\\24 HOUR URINE VOLUME 0.100\\.br\\\\.br\\SERUM CREATININE LEVEL 511 HI 64 - 110';
my $regex = qr/(creatinine).*?(\d+)\D*(\d+\s*-\s*\d+)?/ip;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}