$re = '/(creatinine).*?(\d+)\D*(\d+\s*-\s*\d+)?/i';
$str = 'TEST RESULT\\.br\\COLLECTION DATE 6-FEB-2014\\.br\\24 HOUR URINE VOLUME 0.100\\.br\\\\.br\\SERUM CREATININE LEVEL 511 HI 64 - 110';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);